О Перестройке

Перестройка 2002

Версия 1.1

Дополнительные инструменты для Microsoft Word 2000/2002

Пакет программ на Visual Basic for Applications расширяющих возможности форматирования и редактирования.
Распространяется бесплатно. Может использоваться всеми принявшими условия лицензионного соглашения.

Перечень файлов дистрибутива:

RbMacro.DOT | — | шаблон (template) с программами и панелями (toolbars)
RbMacro.CHM | — | файл помощи
RbMacro.MID | — | MIDI файл
RbHyphen.DOC | — | пример файла-списка для выполнения замен по списку
RbNormal.DOC | — | пример файла-списка для выполнения замен по списку
License.RTF | — | Лицензионное соглашение

Copyright © Сергей Михайлович Хозяинов, 1996-2001

Home Page: | http://calends.webzone.ru http://calends.euro.ru http://stop.at/smh
E-mail: | calends@euro.ru smh@stop.at


Описание и область применения

Перестройка — это дополнительные инструменты для форматирования и редактирования документов, которые можно использовать как с русской, так и с английской версией Microsoft Word 2000/2002. В последнем случае Windows должна быть правильно настроена для поддержки русского языка, т.к. все диалоги выполнены на русском.

При оформлении текста постоянно приходится подбирать параметры абзацев, строк и слов. Рассмотрим типичный случай. Допустим, для того чтобы текст хорошо расположился на странице, необходимо один из абзацев поджать (подтянуть) таким образом, чтобы в нем стало на строку меньше. Этого можно достичь уменьшая межбуквенное расстояние (Character spacing) текста всего абзаца или нескольких его строк, слов. Текст станет плотнее и абзац уложится в меньшее число строк. Подбирая оптимальное значение межбуквенного расстояния, изменять его придется несколько раз, для чего снова и снова проходить все пункты меню MS Word. То же или примерно то же придется делать при подборе величины абзацных отступов, интерлиньяжа, размера шрифта. Использование Перестройки избавит от беготни по меню и упростит форматирование текста.

Перестройка оптимизирует размер межсловных пробелов, разберется с короткими строками абзацев, наведет порядок в языковых установках, устранит многочисленные досадные ошибки набора или OCR программ (лишние пробелы, неправильное использование пробелов со скобками и знаками препинания, вечная неразбериха с тире и дефисами и т.д.).

Перестройка позволит проставить знак ударения над любой буквой, выполнить разрядку текста, перекодировать текст набранный при ошибочно включенной раскладке клавиатуры другого языка (русского или английского), быстро форматировать и переформатировать таблицы и формулы, подсчитать объем документа в учетно-издательских листах, выполнить замены по редактируемому списку замен, легко и быстро преобразовать таблицу в схему состоящую из окон и линий (стрелок) соподчинения, печатать брошюры на принтере, конвертировать документы в формат HTML с сохранением минимального числа параметров форматирования и пр.

Подробнее см. описание панелей:


Установка и удаление

Перед установкой

Необходимо чтобы Microsoft Word 2000/2002 был уже установлен. Убедитесь в том, что в системе присутствует шрифт Tahoma. Все диалоги оформлены этим шрифтом и его отсутствие изменит вид текста в диалогах против замысла автора. Шрифт Tahoma (Tahoma.TTF) входит в состав дистрибутива Microsoft Office.

Установка

  • Закройте MS Word.
  • Запустите программу установки RB2002.EXE и следуйте ее указаниям.
  • Запустите MS Word. Если панели RbMacro, RbTools, RbFormat и RbFormatAlt не будут видны, выберите пункт меню Вид|Панели инструментов|Настройка (View|Toolbars|Customize), на закладке Панели инструментов (Toolbars) установите галочки у названий этих панелей и нажмите кнопку Закрыть (Close).

Если у Вас была установлена Перестройка одной из предыдущих версий, то программа установки ее обновит.

Удаление

  • Закройте MS Word.
  • Выберите в группе Перестройка 2002 главного меню Windows ярлык Удалить или воспользуйтесь сервисом Панель управления|Установка и удаление программ (Control Panel|Add-Remove Programs).


Панель RbMacro

Эта панель предназначена для управления другими панелями пакета, вызова помощи и краткой справки.

Показать/скрыть Панель RbFormat

Показывает или скрывает панель RbFormat. Щелчок мышью по кнопке при нажатой клавише Ctrl приведет к тому, что панель RbFormat будет заменена на свой альтернативный вариант RbFormatAlt (или наоборот).

Показать/скрыть Панель RbTools

Показывает или скрывает панель RbTools.

Показать/скрыть Панель RbStyles

Создает, показывает или скрывает панель RbStyles со стилями документа. Нажимая кнопки RbStyles, можно оформлять текст стилями. При небольшом числе стилей такой способ может быть удобнее стандартных. Панель RbStyles создается и сохраняется в шаблоне документа. А вот так она может выглядеть:

где:

Body Text, Heading 1—3 — имена стилей документа.

Управление панелью. Открывает диалог настройки панелей. Чтобы облегчить панель RbStyles и убрать с нее кнопки с именами некоторых стилей, можно просто перетащить мышью кнопки с панели RbStyles на панель настройки.

Вызов стандартного диалога Стиль (Style).

Помощь

Вызывает файл помощи RbMacro.CHM.

О Перестройке

Краткая информация о Перестройке.

Вверх


Панель RbTools

Сегодня

Показывает сегодняшнюю дату, возраст и фазу Луны.

Переоткрыть файл

Закрывает файл документа без сохранения, открывает его снова, восстанавливает режимы просмотра и устанавливает курсор на ту страницу, на которой тот был до закрытия файла.

Запомнить состояние документа и Отменить изменения

Щелчок мыши по первой кнопке приводит к запоминанию текущего состояния документа. Если после этого внести в документ изменения и щелкнуть по второй кнопке, то изменения будут отменены и документ вернется в прежнее состояние.

Перестройка текста

Исправление типичных ошибок набора, перестройка (конвертирование) текстовых файлов (Text File, MS-DOS Text) и исправление ошибок в текстах полученных после сканирования с использованием OCR программ.

Пояснения к некоторым опциям:

  • Последовательные операции с концом абзаца (¶). При перестройке текста содержащего таблицы в формате Word, вставка или удаление символа конца абзаца внутри таблиц не производится.
  • Удалить переносы разорванные знаком ¶ (т.е. дефис+¶). Такие переносы часто встречаются в файлах в формате MS-DOS Text. Символ дефиса в конце строки может быть не только переносом, но и, собственно, дефисом, и тире, и минусом или быть частью линии. Программа не спутает дефис с переносом в тех частицах, которые в русском языке всегда пишутся через дефис (где-то, как-то, кого-нибудь и пр.). Все остальные дефисы и переносы будут удалены. Минусы, тире и линии сохранятся.
  • Упорядочить пробелы вокруг круглых, квадратных и фигурных скобок. Программа исходит из того, что в тексте (но не в формуле) пробел должен быть перед открывающейся скобкой и после закрывающейся скобки и не должно быть пробела после открывающейся скобки и перед закрывающейся скобкой.
  • Упорядочить пробелы в сокращениях (им., т. к., т. е., и т. д., и т. п., и пр.). Указанные сокращения будут оформлены следующим образом:
    им.º
    т.ºк.º
    т.ºе.º
    иºт.ºд.
    иºт.ºп.
    иºпр.

    где, º — неразрывный пробел.
  • Заменить No и N используемые вместо знака номера на No. No и N внутри английских слов останутся нетронутыми. Программа исходит из того, что после знака номера идут цифры или знаки подчеркивания.
  • Упорядочить использование многоточия. Три точки следующие подряд будут заменены на символ троеточия (…). Учитывается правописание восклицательного и вопросительного знаков с многоточием (!.. и ?..).

Альтернативой этому инструменту является инструмент Замены по списку, для использования которого необходимо разбираться в опциях поиска и замены Microsoft Word. Это позволит оформлять сокращения, инициалы, знаки препинания и пр. и пр. в соответствии со своими представлениями о том, как это должно быть.

Замены по списку

Последовательно выполняет замены описанные в специальных файлах-списках. Замены описываются в таблице. Чтобы задействовать тот или иной параметр поиска, впишите в соответствующую клетку таблицы любой символ. Добавьте в таблицу столько строк сколько требуется. Замены выполняются без подтверждения в выделенном фрагменте документа. Разумеется можно выделить и весь документ целиком. При необходимости можно создать много файлов-списков с разными именами.

В поставку входят два примера файлов-списков:

  • RbHyphen.DOC — для расстановке в тексте мягких переносов.
  • RbNormal.DOC — для автоматической правки распространенных ошибок набора.

Пояснения к структуре таблицы с описанием замен:

  • Найти — указать что искать.
  • Учитывать назв. шрифта — поставить “x” (или любой др. символ), чтобы поиск учитывал название шрифта, которым набран текст для поиска.
  • Заменить на — указать на что заменять.
  • Учитывать назв. шрифта — поставить “x” (или любой др. символ), чтобы поиск учитывал название шрифта, которым набран текст для замены.
  • Регистр — поставить “x” (или любой др. символ), чтобы поиск учитывал регистр.
  • Слово целиком — поставить “x” (или любой др. символ), чтобы искать целое слово.
  • Подстановочные знаки — поставить “x” (или любой др. символ), чтобы использовать подстановочные знаки.
  • Примечание — произвольный текст, комментарий.

Подробнее о поиске и замене см. Специальные символы и подстановочные знаки в операциях поиска и замены

Жидкие абзацы

Оптимизация размера пробелов подбором трекинга абзаца. Программа находит абзацы с пробелами, величины которых превосходят указанный размер, и подбирает для всего абзаца оптимальный трекинг, изменяя его значение в заданном диапазоне. Абзацы содержащие фрагменты текста с различным трекингом игнорируются.

Короткие строки

Короткие строки ухудшают внешний вид текста и в профессиональной верстке не допускаются. Программа ищет абзацы, число знаков в последней строке которых меньше разрешенного, и подбором величины трекинга в заданном диапазоне стремится так перестроить абзац, чтобы его последняя строка перестала быть короткой. Абзацы содержащие фрагменты текста с различным трекингом игнорируются.

Форматирование таблиц

Позволяет быстро оформлять таблицы. Сначала надо поставить текстовой курсор в любую таблицу, запустить программу и подобрать оформление для нее. Затем выделить весь документ или его часть и программа оформит соответствующим образом все таблицы попавшие в выделение.

Форматирование формул

Позволяет быстро оформить формулы (Equation Objects) в соответствии с текущими установками формульного редактора (Microsoft Equation). Поясню на примере. Допустим, имеется документ с десятками формул и требуется их переоформить. Сначала надо запустить формульный редактор и настроить стили оформления (шрифты, начертания, размеры) по своему усмотрению. Затем формульный редактор надо закрыть, выделить весь документ или его часть и программа оформит все формулы попавшие в выделение согласно указанным настройкам.

Чтение

Чтение выделенного фрагмента документа. Требует установки Microsoft Agent, который можно свободно загрузить со страницы http://www.microsoft.com/MSAGENT/downloads.htm. Для чтения русского текста обязательно следует загрузить следующие модули:

  • Microsoft Agent core components.
  • Russian Language to the core components (Русский интерфейс для Microsoft Agent core components).
  • Microsoft Agent character files (Анимированные персонажи читающие текст. Надо загрузить хотя бы одного.).
  • Text-to-speech engines - Russian (Модуль синтеза речи для русского языка).
  • Speech Control Panel.

Для других языков дополнительно потребуется соответствующий модуль Text-to-speech engines.

Для старта/остановки чтения достаточно выделить фрагмент текста и щелкнуть левой кнопкой мыши по персонажу. Щелчок правой кнопки мыши откроет диалог настройки параметров.

Копирование текущей ячейки таблицы во все другие

Содержимое текущей ячейки таблицы (текст, рисунки, линии, встроенные объекты) будет копировано во все ячейки таблицы. Позволяет упростить и ускорить изготовление этикеток, ценников, визитных карточек и т.п.

Языковые инструменты

В зависимости от выбора пользователя выполняет следующие действия над выделенным фрагментом текста документа:

  • Ищет русские слова и устанавливает для них Русский язык (Russian (Russia)).
  • Ищет английские слова и устанавливает для них Английский язык (English (U.S.)).
  • Ищет слова, состоящие из смеси русских и английских букв, анализирует их и заменяет английские буквы в русских словах на русские и наоборот. В русском и английском алфавитах есть буквы, совпадающие по начертанию (асеорхуАВСЕНКМОРТХ). Наборщики иногда набирают русские буквы вместо английских или английские вместо русских. Много ошибок такого рода делают программы распознания текста (OCR программы). Внешне такие слова ничем не приметны, однако на них всегда спотыкается проверка орфографии (Spelling) и алгоритмы переносов не могут работать с ними.
  • Ищет фрагменты текста содержащие надстрочные и/или подстрочные символы и отменяет для них проверку правописания (Do not check spelling or grammar).

Фрагменты

Копирование/перемещение в позицию курсора или удаление выделенных цветом фрагментов текста. Если выделить цветом (Highlight) несколько фрагментов текста, то все они будут собраны в позицию курсора в том порядке, в котором следуют в документе, или удалены.

Просмотр шрифтов

Просмотр установленных в системе шрифтов.

Таблица символов

Просмотр таблицы символов шрифтов.

Преобразование таблицы в схему

Построение схемы из окон и линий на основе таблицы. Перед запуском необходимо установить текстовой курсор внутрь таблицы. Будет создан новый документ и на его первой странице построена схема. Относительные положение и ширина каждого окна схемы будут соответствовать положению и ширине соответствующей ячейки таблицы, а текст из ячеек таблицы в окна схемы скопируется с сохранением текстовых атрибутов и стиля. Полученную схему можно перенести в любой другой документ.

Объем документа

Подсчет объема документа(ов) в учетно-издательских листах. Можно подсчитать объем как одного текущего документа, так и всех документов лежащих с ним в одном каталоге. 40000 печатных знаков (с пробелами) или 3000 кв. см графики составляют 1 уч.-изд. лист. Формулы (объекты Equation) учитываются по площади. Все остальные изображения и объекты считаются графикой и учитываются по площади.

Обратите внимание на то, что для выбора нескольких строк списка можно использовать клавиши Shift и Ctrl, а для удаления строк можно использовать клавишу Delete.

Печать текущей страницы

Печать текущей страницы в 1 экз. Печать происходит без запроса на подтверждение с установками принтера по умолчанию.

Печать тетрадями

Печать документа тетрадями. Можно использовать для печати брошюр на принтере или подготовки оригинал-макетов для оперативной печати на ризографе.

Пояснения к настройкам:

  • Диапазон стр. док-та для печати — указать диапазон страниц документа, которые необходимо распечатать тетрадями.
  • Параметры тетради — указать число страниц в тетради.
  • Что печатать — указать будет ли распечатываться одна конкретная тетрадь или все сразу.
  • Рассчитать спуск полос — расчет пар страниц, которые будут распечатаны на одной и другой стороне листа бумаги. Прежде следует указать диапазон страниц для печати и установить параметры тетради. Номера пар страниц будут указаны в окнах 1-я сторона листа и 2-я сторона.
  • Печать — печать указанных страниц. Сначала мышью выделите те пары страниц, которые необходимо напечатать (для выбора нескольких строк списка можно использовать клавиши Shift и Ctrl).

Вставка

Быстрая вставка в документ символа, формулы, сноски, файла, картинки, объектов Clip Art, Chart, Excel и др.

Запуск Проводника Windows

Открытие каталога текущего документа в программе Проводник (Explorer).

Конвертирование в HTML

Сохраняет документ в формате HTML с сохранением минимального числа параметров форматирования:

  1. Текстовые выделения:
    • Курсив
    • Полужирный
    • Подчеркивание одной линией
  2. Стили:
    • Стили абзацев и определенные пользователем стили символов
  3. Списки (нумерованные и маркированные):
    • Сохраняются уровни вложенности
    • Не сохраняются виды нумерации (цифры, буквы и пр.) и символы используемые для маркировки
  4. Отступ слева:
    • Сохраняется с использованием тегов <blockquote> и </blockquote>
  5. Сноски:
    • Сохраняются в конце документа и нумеруются насквозь
  6. Ссылки:
    • Сохраняются ссылки для навигации внутри документа и ссылки http и e-mail
  7. Рамки (Frames) и Надписи (TextBoxes):
    • Рамка (Frame) сохраняется как обычный текст без рамки
    • Надпись (TextBox) сохраняется как изображение
  8. Таблицы:
    • Таблицы со слитыми клетками удаляются и на их место вставляется красный текст вида: Сюда табл. со стр. такой-то такого-то файла
    • В прочих таблицах сохраняется только структура. Рамки, ширина, длина и цвет не сохраняются
  9. Изображения:
    • Сохраняются в каталоге ИмяДокумента_files как gif или jpg.
    • Если не удается сохранить изображение, то дается ссылка не отсутствующий gif файл в каталоге ИмяДокумента_files с альтернативным текстом: Сюда картинку со стр. такой-то такого-то файла

Проблемы:

  1. Не работает с таблицами со слитыми клетками.
  2. Изображения плавающие над текстом могут уйти со своего места.
  3. Не сохраняются знаки символьных шрифтов.

Пятнашки

Игра в Пятнашки.

Запуск Калькулятора

Запуск и/или активация программы Калькулятор (Calculator).

Запуск Пасьянса

Запуск или активация программы Пасьянс "Косынка" (Solitaire).

Вверх


Панель RbFormat

Инструменты панелей RbFormat и RbFormatAlt функционально тождественны. Панель RbFormatAlt занимает меньше места на экране, но при работе с ней часто приходится использовать клавиши Shift и Ctrl.

Опустить знаки

Смещение вниз на 1/10 размера шрифта с минимальным шагом в 1 pt. Если выделенный текст содержит фрагменты уже смещенного вверх или вниз текста, то каждый из них смещается вниз на 1/10 размера шрифта.

Позиция как в стиле

Установка позиции знаков текста относительно базовой линии соответствующей стилю абзаца.

Поднять знаки

Смещение вверх на 1/10 размера шрифта с минимальным шагом в 1 pt. Если выделенный текст содержит фрагменты уже смещенного вверх или вниз текста, то каждый из них смещается вверх на 1/10 размера шрифта.

Уменьшить трекинг

Уменьшение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг уменьшается на 1/100 размера шрифта.

Трекинг как в стиле

Установка трекинга соответствующего стилю абзаца.

Увеличить трекинг

Увеличение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг увеличивается на 1/100 размера шрифта.

Уменьшить трекинг

Уменьшение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг уменьшается на 1/100 размера шрифта. Если трекинг становится меньше стилевого, то текст выделяется красным цветом.

Трекинг как в стиле

Установка трекинга соответствующего стилю абзаца. Если трекинг становится равен стилевому, то текст оформляется цветом указанным в стиле.

Увеличить трекинг

Увеличение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг увеличивается на 1/100 размера шрифта. Если трекинг становится больше стилевого, то текст выделяется синим цветом.

Уменьшить знаки

Уменьшение размера шрифта. Если выделенный текст содержит фрагменты с различным размером шрифта, то шрифт пропорционально уменьшается в каждом из них.

Размер как в стиле

Установка размера шрифта соответствующего стилю абзаца.

Увеличить знаки

Увеличение размера шрифта. Если выделенный текст содержит фрагменты с различным размером шрифта, то шрифт пропорционально увеличивается в каждом из них.

Сжать знаки

Сжатие знаков текста на 5%. Если выделенный текст содержит фрагменты с уже сжатыми или растянутыми знаками, то знаки каждого из них сжимаются на 5%.

Растяжение как в стиле

Установка степени сжатия или растяжения знаков текста соответствующей стилю абзаца.

Растянуть знаки

Растяжение знаков текста на 5%. Если выделенный текст содержит фрагменты с уже сжатыми или растянутыми знаками, то знаки каждого из них растягиваются на 5%.

Уменьшить отступ перед абзацем

Уменьшение отбивки перед абзацем на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка уменьшается на 1 pt.

Отступ перед абзацем как в стиле

Установка отбивки перед абзацем соответствующей стилю абзаца.

Увеличить отступ перед абзацем

Увеличение отбивки перед абзацем на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка увеличивается на 1 pt.

Уменьшить отступ после абзаца

Уменьшение отбивки после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка уменьшается на 1 pt.

Отступ после абзаца как в стиле

Установка отбивки после абзаца соответствующей стилю абзаца.

Увеличить отступ после абзаца

Увеличение отбивки после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка увеличивается на 1 pt.

Уменьшить отступы перед и после абзаца

Уменьшение отбивки перед и после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них соответствующая отбивка уменьшается на 1 pt.

Отступы перед и после как в стиле

Установка отбивок перед и после абзаца соответствующими стилю абзаца.

Увеличить отступы перед и после абзаца

Увеличение отбивки перед и после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них соответствующая отбивка увеличивается на 1 pt.

Уменьшить интерлиньяж

Уменьшение интерлиньяжа на 0.01 li. Если выделенный текст содержит фрагменты с различным интерлиньяжем, то в каждом из них интерлиньяж уменьшается на 0.01 li.

Интерлиньяж как в стиле

Установка интерлиньяжа соответствующего стилю абзаца.

Увеличить интерлиньяж

Увеличение интерлиньяжа на 0.01 li. Если выделенный текст содержит фрагменты с различным интерлиньяжем, то в каждом из них интерлиньяж увеличивается на 0.01 li.

Вставка пары кавычек «»

Вставка или удаление пары кавычек в позиции курсора или вокруг выделенного текста.

Вставка пары кавычек “”

Вставка или удаление пары кавычек в позиции курсора или вокруг выделенного текста.

Вставка пары скобок ()

Вставка или удаление пары круглых скобок в позиции курсора или вокруг выделенного текста.

Ударение

Ударение или его отмена. Знак ударения ставится над одним выделенным символом или над символом стоящим слева от курсора.

См. Возможные проблемы

Надчеркивание

Надчеркивание или его отмена. Выделенный текст (не длиннее одной строки) преобразуется в формулу с линией над ним или выполняется обратная операция.

Числитель/Знаменатель в дробь

Преобразование фрагмента текста вида Числитель/Знаменатель в дробь и обратно.

См. Возможные проблемы

Замена знаков QWERTY ЙЦУКЕН

Перекодировка текста набранного при ошибочно включенной раскладке клавиатуры другого языка (русского или английского). Раскладка знаков должна соответствовать принятой в Windows по умолчанию.

Разрядка

Разрядка или ее отмена. Разрядка достигается установкой трекинга равного 1/3 размера шрифта. Повторное нажатие на кнопку устанавливает трекинг соответствующий стилю абзаца. В разряженном тексте знаки препинания, скобки и кавычки не отскакивают от слов.

Расположение окон

Взаимное расположение окон открытых документов.

Уменьшить масштаб просмотра

Уменьшение масштаба просмотра на 5%.

Масштаб просмотра по ширине страницы

Установка масштаба просмотра по ширине страницы.

Увеличить масштаб просмотра

Увеличение масштаба просмотра на 5%.

Вверх


Панель RbFormatAlt

Инструменты панелей RbFormat и RbFormatAlt функционально тождественны. Панель RbFormatAlt занимает меньше места на экране, но при работе с ней часто приходится использовать клавиши Shift и Ctrl.

Ударение

Ударение или его отмена. Макрос ставит знак ударения над одним выделенным символом или над символом стоящим слева от курсора.

См. Возможные проблемы

Позиция знаков

Изменение позиции знаков текста относительно базовой линии.

Щелчок мыши — Установка позиции знаков текста относительно базовой линии соответствующей стилю абзаца.

Shift + Щелчок мыши — Смещение вверх на 1/10 размера шрифта с минимальным шагом в 1 pt. Если выделенный текст содержит фрагменты уже смещенного вверх или вниз текста, то каждый из них смещается вверх на 1/10 размера шрифта.

Ctrl + Щелчок мыши — Такое же смещение вниз.

Трекинг знаков

Изменение трекинга знаков.

Щелчок мыши — Установка трекинга соответствующего стилю абзаца.

Shift + Щелчок мыши — Увеличение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг увеличивается на 1/100 размера шрифта.

Ctrl + Щелчок мыши — Такое же уменьшение трекинга.

Трекинг знаков

Изменение трекинга знаков.

Щелчок мыши — Установка трекинга соответствующего стилю абзаца. Если трекинг становится равен стилевому, то текст оформляется цветом указанным в стиле.

Shift + Щелчок мыши — Увеличение трекинга на 1/100 размера шрифта с минимальным шагом в 0.1 pt. Если выделенный текст содержит фрагменты с различным трекингом и размером шрифта, то в каждом из них трекинг увеличивается на 1/100 размера шрифта. Если трекинг становится больше стилевого, то текст выделяется синим цветом.

Ctrl + Щелчок мыши — Такое же уменьшение трекинга. Если трекинг становится меньше стилевого, то текст выделяется красным цветом.

Размер знаков

Изменение размера шрифта.

Щелчок мыши — Установка размера шрифта соответствующего стилю абзаца.

Shift + Щелчок мыши — Увеличение размера шрифта. Если выделенный текст содержит фрагменты с различным размером шрифта, то шрифт пропорционально увеличивается в каждом из них.

Ctrl + Щелчок мыши — Такое же уменьшение размера шрифта.

Растяжка знаков

Сжатие или растяжение знаков текста.

Щелчок мыши — Установка степени сжатия или растяжения знаков текста соответствующей стилю абзаца.

Shift + Щелчок мыши — Растяжение знаков текста на 5%. Если выделенный текст содержит фрагменты с уже сжатыми или растянутыми знаками, то знаки каждого из них растягиваются на 5%.

Ctrl + Щелчок мыши — Такое же сжатие знаков текста.

Отступ перед абзацем

Изменение отбивки перед абзацем.

Щелчок мыши — Установка отбивки перед абзацем соответствующей стилю абзаца.

Shift + Щелчок мыши — Увеличение отбивки перед абзацем на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка увеличивается на 1 pt.

Ctrl + Щелчок мыши — Такое же уменьшение отбивки перед абзацем.

Отступ после абзаца

Изменение отбивки после абзаца.

Щелчок мыши — Установка отбивки после абзаца соответствующей стилю абзаца.

Shift + Щелчок мыши — Увеличение отбивки после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них отбивка увеличивается на 1 pt.

Ctrl + Щелчок мыши — Такое же уменьшение отбивки после абзаца.

Отступы перед и после абзаца

Изменение отбивок перед и после абзаца.

Щелчок мыши — Установка отбивок перед и после абзаца в соответствии со стилем абзаца.

Shift + Щелчок мыши — Увеличение отбивки перед и после абзаца на 1 pt. Если выделенный текст содержит фрагменты с различными отбивками, то в каждом из них соответствующая отбивка увеличивается на 1 pt.

Ctrl + Щелчок мыши — Такое же уменьшение отбивок перед и после абзаца.

Интерлиньяж

Изменение интерлиньяжа абзаца.

Щелчок мыши — Установка интерлиньяжа соответствующего стилю абзаца.

Shift + Щелчок мыши — Увеличение интерлиньяжа на 0.01 li. Если выделенный текст содержит фрагменты с различным интерлиньяжем, то в каждом из них интерлиньяж увеличивается на 0.01 li.

Ctrl + Щелчок мыши — Такое же уменьшение интерлиньяжа.

Вставка пары кавычек

Вставка пары кавычек «» в позицию курсора или вокруг выделенного текста.

Ctrl + Щелчок мыши — Вставка пары кавычек “” в позицию курсора или вокруг выделенного текста.

Вставка пары скобок ()

Вставка пары круглых скобок в позицию курсора или вокруг выделенного текста.

Надчеркивание

Надчеркивание или его отмена. Макрос преобразует текст в формулу с линией над ней или проделывает обратную операцию.

Числитель/Знаменатель в дробь

Преобразование фрагмента текста вида Числитель/Знаменатель в дробь и обратно.

См. Возможные проблемы

Перекодировка знаков QWERTY ЙЦУКЕН

Перекодировка текста набранного при ошибочно включенной раскладке клавиатуры другого языка (русского или английского). Раскладка знаков должна соответствовать принятой в Windows по умолчанию.

Разрядка

Разрядка или ее отмена. Макрос устанавливает трекинг равный 1/3 размера шрифта (для разрядки текста) или устанавливает трекинг соответствующий стилю абзаца. В разряженном тексте знаки препинания, скобки и кавычки не отскакивают от слов.

Масштаб просмотра

Изменение масштаба просмотра.

Щелчок мыши — Установка масштаба просмотра 100%.

Shift + Щелчок мыши — Увеличение масштаба просмотра на 5%.

Ctrl + Щелчок мыши — Такое же уменьшение масштаба просмотра.

Расположение окон

Взаимное расположение окон открытых документов.

Вверх


Рекомендации по использованию

Для управления инструментами Перестройка предлагает четыре панели с кнопками (RbMacro, RbTools, RbFormat и RbFormatAlt) и добавляет пункт меню Перестройка на панель Строка меню (Menu Bar). Вы можете самостоятельно создать свой произвольный набор кнопок на своей панели и создать свое меню. Это легко делается стандартными средствами Microsoft Word и совсем не требует специальных знаний. Например, для экономии места на экране кнопки панели RbMacro можно копировать на одну из стандартный панелей (например, на панель Строка меню (Menu Bar)), а панель RbMacro закрыть.

Не забывайте назначать "быстрые клавиши".

Для форматирования одного абзаца (отступы, интерлиньяж) предварительно выделять его не надо. Будет отформатирован тот абзац, в котором находится текстовой курсор. Это относится и к работе с "жидкими" абзацами и с абзацами с короткими строками.

Аналогично, для форматирования одного слова (позиция, трекинг, размер, степень растяжения знаков) предварительно выделять его не надо. Отформатируется то слово, в котором находится текстовой курсор. Это относится и к разрядке текста, и к надчеркиванию, и к перекодировке знаков (QWERTY ЙЦУКЕН).

Для установки знака ударения над буквой выделять ее необязательно. Знак ударения проставляется над буквой стоящей слева от курсора.

Для преобразования фрагмента текста вида Числитель/Знаменатель в дробь выделять его необязательно. Достаточно поставить текстовой курсор внутрь фрагмента и нажать на кнопку "Числитель/Знаменатель в дробь".

Все инструменты Перестройки можно использовать и в режиме Предварительный просмотр (Print Preview), и в режиме Во весь экран (Full Screen).

Чтобы прервать работу нажимайте Esc или Ctrl+Break.

Программы, работа которых может занять длительное время, по завершении выдают звуковой сигнал и сообщение в Строку состояния (Status Bar).

Обращайте внимание на Строку состояния. На ней отображается ход и статистика работы.


Возможные проблемы

Установка знака ударения и преобразование фрагмента текста вида Числитель/Знаменатель в дробь работают по одному принципу. Они вставляют в текст, так называемые, поля (fields). Синтаксис этих полей требует использования специального знака — разделителя элементов списка (List Separator). В разных странах в качестве разделителя выступают разные символы (см. Панель управления|Язык и стандарты|Числа|Разделитель элементов списка или Control Panel|Regional Options|Numbers|List Separator). В России разделителем элементов списка является точка с запятой, в США — запятая.

Таким образом, если работая на одном компьютере проставить в документе ударения, а затем просматривать его на другом компьютере, и на этих компьютерах в настройках Windows установлены разные разделители элементов списка, то возникнет ошибка и знаки ударения не будут показаны правильно.

Чтобы увидеть коды полей проделайте следующее. Выделите часть текста с полями или весь текст, щелкните по тексту правой кнопкой мыши и выберите в появившемся меню пункт Коды/значения полей (Toggle Field Codes) или нажмите Alt+F9. Для возврата в режим показа значений полей повторно выберите Коды/значения полей или нажмите Alt+F9.

Пример кодов полей

Ударение над буквой «о» в слове корóва

Разделитель элементов списка — точка с запятой: кор{eq \o (о;')}ва
Разделитель элементов списка — запятая: кор{eq \o (о,')}ва

Преобразование в дробь 1/2

Разделитель элементов списка — точка с запятой: {eq \f (1;2)}
Разделитель элементов списка — запятая: {eq \f (1,2)}

Способы решения проблемы

  1. Установить разделитель элементов списка (List Separator) используемый в документе.
  2. Произвести глобальную замену символа разделителя элементов списка в документе.

После установки Перестройки при запуске MS Word может появляться сообщение "Could not load an object because it is not available on this machine". Так бывает в тех случаях, когда при установке MS Office не был установлен ни один помощник (Office Assistant). Запустите программу установки MS Office и доустановите одного любого помощника. Сразу после этого помощника можно удалить. Указанное сообщение больше появляться не будет.

На некоторых компьютерах наблюдается следующий дефект. Кнопки не панелях выглядят темными, как если бы изображение было нанесено поверх интенсивного темно-серого фона. В этом случае следует установить новую версию драйвера видеокарты.


Лицензионное соглашение

Лицензионное соглашение на использование программы Перестройка 2002 (Версия 1.1)

Настоящее лицензионное соглашение (далее "Соглашение") является договором, заключаемым между конечным пользователем (далее "Пользователем") и Хозяиновым Сергеем Михайловичем (далее "Автором") относительно программы Перестройка 2002 версии 1.1 (далее "Программа"), включающего в себя саму Программу и встроенную в нее документацию. Устанавливая, копируя или иным образом используя Программу, Пользователь тем самым принимает на себя условия Соглашения. Если Пользователь не принимает условий Соглашения, то он не имеет права использовать Программу.

Автор оставляет за собой право изменить Соглашение для любой из следующих версий Программы.

1. Предмет лицензии

Предметом лицензии является право использования Программы, относительно которой Автор утверждает, что она является продуктом его интеллектуальной деятельности и все авторские и иные права на нее принадлежат Автору.

2. Объем лицензии

При условии ссылки на Автора как на владельца авторских прав на Программу Автор предоставляет Пользователю неисключительное и свободное от лицензионных платежей право:

  • распространять и воспроизводить любое количество копий Программы на любом числе компьютеров;
  • передавать Программу третьим лицам, согласившимся с условиями Соглашения.

3. Услуги по обеспечению

Автор предоставляет Программу "как есть" и не берет на себя обязательств предоставлять Пользователю поддержку.

4. Ограничения

Пользователь обязан:

  • сохранять или воспроизводить все уведомления об авторских правах на всех копиях Программы;
  • использовать Программу в соответствии с действующим законодательством.

Пользователь не имеет права:

  • любым образом изменять Программу и встроенную в нее документацию;
  • вскрывать технологию и декомпилировать Программу за исключением случая и только в той степени, когда такие действия явно разрешены действующим законодательством несмотря на наличие в Соглашении данного ограничения;
  • встраивать Программу полностью или частично в свои программные продукты без письменного разрешения Автора;
  • брать плату за распространение Программы.

5. Авторское право

Все авторские права на Программу принадлежат Автору. Программа защищена законами и международными соглашениями об авторских правах, а также положениями иных законов и международных договоров в области интеллектуальной собственности.

6. Отказ от гарантий

Пользователь отвечает за любое использование Программы. В наибольшей степени, допускаемой действующим законодательством, Автор отказывается от предоставления любых гарантий, явных или подразумеваемых, в том числе безвредности или применимости Программы для какой-либо конкретной цели.

7. Отказ от ответственности за косвенный ущерб

В наибольшей степени, допускаемой действующим законодательством, Автор отказывается нести ответственность за какой-либо конкретный, случайный, косвенный или связанный ущерб (куда входят, в том числе, все без исключения виды потерь: недополученная прибыль, потеря важной информации или любые другие убытки), возникший из-за использования или невозможности использования Программы, даже если Автор был предупрежден о возможности возникновения такого ущерба.

8. Ограничение суммы ответственности

Вся возможная совокупная ответственность Автора при возмещении ущерба Пользователю по Соглашению не может превысить суммы, эквивалентной одному рублю Российской Федерации.


Специальные символы и подстановочные знаки в операциях поиска и замены

Строка поиска
Строка замены
Замечания по синтаксису
Примеры

Существуют два типа специальных знаков — специальные символы и подстановочные знаки.

Специальными символами называют символы которых нет на клавиатуре и/или которые невозможно непосредственно вписать в строку поиска или замены. Например: принудительный обрыв строки, мягкий перенос, неразрывный пробел и т. п.

Если в диалоге поиска и замены задействована опция Подстановочные знаки (Use wildcards), то становится возможным формировать сложные условия поиска. Для этого используются подстановочные знаки. С их помощью можно задавать диапазоны символов и выражения отвечающие ряду условий.

Некоторые символы и знаки можно использовать только в строке поиска, некоторые — только в строке замены. Возможность использования других зависит от того задействована или нет опция Подстановочные знаки (Use wildcards). Для их ввода в строки поиска и замены удобно использовать кнопку Специальный (Special) в диалоге поиска и замены.

Ниже приведен полный список символов и знаков.

А еще ниже — примеры их использования.

Строка поиска

Специальные символы, которые можно использовать только в том случае, если опция Подстановочные знаки (Use wildcards) не задействована.

^p | Paragraph mark (¶) | Символ конца абзаца (¶)
^? | Any character | Любой символ
^# | Any digit | Любая цифра
^$ | Any letter | Любая буква
^e | Endnote mark | Концевая сноска
^d | Field | Поле
^f | Footnote mark | Сноска
^b | Section break (===End of Section===) | Обрыв секции (===End of Section===)
^w | White space | Любое число и любая комбинация обыкновенных и неразрывных пробелов, табуляций и концов абзаца

Специальные символы, использование которых не зависит от опции Подстановочные знаки (Use wildcards).

^t | Tab character (®) | Символ табуляции (®)
^a | Comment mark | Комментарий
^0nnn | ANSI or ASCII characters | Любой ANSI или ASCII символ с кодом nnn
^^ | Caret character | Символ ^
^g | Graphic | Графика
^n | Column break (···Column Break···) | Обрыв колонки (···Column Break···)
^l | Manual line break (ї) | Принудительный обрыв строки (ї)
^m | Manual page break (---Page Break---) | Принудительный обрыв страницы (---Page Break---)
^+ | Em dash (—) | Длинное тире (—). Символ с кодом 0151.
^= | En dash (–) | Короткое тире (–). Символ с кодом 0150.
^s | Nonbreaking space (°) | Неразрывный пробел (°)
^~ | Nonbreaking hyphen (-) | Неразрывный дефис (-)
^- | Optional hyphen (¬) | Мягкий перенос (¬)

Подстановочные знаки, которые можно использовать только в том случае, если опция Подстановочные знаки (Use wildcards) задействована.

Спец. знак | Что обозначает | Пример строки поиска | Что будет находить
? | Один любой символ | б?к | бак, бок, бук, б5к, б¶к и т.п.
* | Любое число любых символов | б*к | бык, бардак, белый.¶Полковник и т.п.
[ ] | Один из указанных символов | б[аоу]к | бак, бок, бук
[-] | Один символ из диапазона. Диапазон должен быть указан в порядке возрастания кодов символов. | [а-яё] | Любая строчная русская буква
 |  | [А-ЯЁ] | Любая прописная русская буква
 |  | [0-9] | Любая цифра
[!] | Один любой символ не указанный после восклицательного знака | б[!ы]к | бак, бок и т.п., но не бык
[!x-z] | Один любой символ не входящий в диапазон указанный после восклицательного знака | [!а-яё]ок | Бок, Док и т.п., но не бок, док
 |  | [!0-9] | Любой символ кроме цифр
{n} | Строго n штук предыдущего символа или выражения. | 10{3} | 1000, но не 100, 10000
 |  | 10(20){2} | 102020, но не 1020, 10202020
{n;} | n и более штук предыдущего символа или выражения | 10{3;} | 1000, 10000, 100000 и т.д. но не 100
{n;m} | От n до m штук предыдущего символа или выражения | 10{3;4} | 1000, 10000, но не 100, 100000
@ | Ноль или более штук предыдущего символа или выражения | 10@> | 10, 100, 1000, 10000 и т.д.
< | Начало слова | <бок | боксер, но не колобок
> | Конец слова | бок> | колобок, но не боксер

Строка замены

Специальные символы, использование которых не зависит от опции Подстановочные знаки (Use wildcards)

^p | Paragraph mark (¶) | Символ конца абзаца (¶)
^t | Tab character (®) | Символ табуляции (®)
^0nnn | ANSI or ASCII characters | Любой ANSI или ASCII символ с кодом nnn
^^ | Caret character | Символ ^
^c | Clipboard contents | Содержимое буфера обмена
^& | Contents of the Find what box | Содержимое строки поиска (или то, что найдено)
^n | Column break (···Column Break···) | Обрыв колонки (···Column Break···)
^l | Manual line break (ї) | Принудительный обрыв строки (ї)
^m | Manual page break (---Page Break---) | Принудительный обрыв страницы (---Page Break---)
^+ | Em dash (—) | Длинное тире (—). Символ с кодом 0151.
^= | En dash (–) | Короткое тире (–). Символ с кодом 0150.
^s | Nonbreaking space (°) | Неразрывный пробел (°)
^~ | Nonbreaking hyphen (-) | Неразрывный дефис (-)
^- | Optional hyphen (¬) | Мягкий перенос (¬)

Подстановочные знаки, которые можно использовать только в том случае, если опция Подстановочные знаки (Use wildcards) задействована.

\n

Expression n

Выражение номер n из строки поиска

Замечания по синтаксису

Точка с запятой в операторах {n;} и {n;m} — это не просто точка с запятой, а, так называемый, Разделитель элементов списка (List separator). В России это точка с запятой, в США — запятая. Чтобы узнать какой символ играет роль разделителя элементов списка в вашей системе, загляните в Панель управления|Язык и стандарты|Числа|Разделитель элементов списка (Control Panel|Regional Settings|Number|List separator).

Для поиска в документе знаков, которые в строке поиска используются как специальные, необходимо набирать перед ними обратный слэш. Например, если задействована опция Подстановочные знаки (Use wildcards), то, чтобы искать восклицательный знак, надо в строке поиска набрать обратный слэш и за ним восклицательный знак.

Примеры

Опция Подстановочные знаки (Use wildcards) должна быть задействована в диалоге поиска и замены. Это условие должно соблюдаться для всех приведенных ниже примеров.

Примеры поиска

Строка поиска | Что будет находить
[!^0013]^0013[!^0013] | Одиночный конец абзаца в окружении двух неконцов. (Подробный разбор см. ниже).
^0013{2;} | Два и более конца абзацев
^0032{2;} | Два и более пробела
[.,:;\!\?] | Знак препинания ( . , : ; ! ? )
[0-9]^0032[0-9] | Две цифры разделенные пробелом
[0-9]^0032[A-Za-zА-яЁё] | Цифра и буква (английская или русская) разделенные пробелом. (Подробный разбор см. ниже).
-[0-9] | Дефис и цифра
<[0-9]@-[0-9]@> | Два целых числа разделенные дефисом
\([0-9]\) | Цифра в круглых скобках
<[0-9]@> | Целое число (точнее — непрерывная последовательность цифр)
<[0-9]@,[0-9]@> | Десятичная дробь набранная через запятую
<[A-Za-z]@> | Английское слово
<[А-яЁё]@> | Русское слово
<[А-ЯЁ][а-яё]@> | Русское слово набранное строчными буквами, но с прописной. (Подробный разбор см. ниже).

Подробный разбор нескольких строк поиска

[!^0013]^0013[!^0013]

[!^0013] | ^0013 | [!^0013]
1 символ строки поиска | 2 символ | 3 символ
Любой символ, но не конец абзаца | Конец абзаца | Любой символ, но не конец абзаца
В квадратных скобках указан символ с кодом 0013 (конец абзаца). Знак "!" указывает на то, что в этой позиции может находится любой символ кроме конца абзаца. | (символ с кодом 0013). | В квадратных скобках указан символ с кодом 0013 (конец абзаца). Знак "!" указывает на то, что в этой позиции может находится любой символ кроме конца абзаца.

[0-9]^0032[A-Za-zА-яЁё¨]

[0-9]

^0032

[A-Za-zА-яЁё]

1 символ строки поиска

2 символ

3 символ

Любая цифра

Пробел

Любая буква (английская или русская)

В квадратных скобках указан диапазон знаков от 0 до 9, т.е. цифры.

(символ с кодом 0032).

Допустимый символ определен тремя диапазонами и двумя конкретными символами.
A-Z — английские прописные буквы;
а-z — английские строчные буквы;
А-я — русские прописные и строчные буквы;
Ёё — прописная и строчная ё (чтобы охватить весь русский алфавит).

<[А-ЯЁ][а-яё]@>

<[А-ЯЁ] | [а-яё]@>
1 позиция строки поиска | 2 позиция
Любая русская прописная буква | Любые русские строчные буквы
В квадратных скобках указан диапазон знаков от А до Я и ¨ (т.е. любая русская прописная буква). Знак "<" указывает на то, что прописная буква должна быть в начале слова. | Диапазон в квадратных скобках определяет все русские строчные буквы. Знак "@" говорит о том, что число русских строчных букв может быть равным или больше нуля. Знак ">" указывает на конец слова.

Об операциях с выражениями

Для работы с выражениями задействуйте опцию Подстановочные знаки (Use wildcards).

В строке поиска выражением является все то, что заключено в круглые скобки (которые в этом случае выступают в роли специальный знаков). Выражение может состоять как из конкретных символов, так и содержать подстановочные знаки или специальные символы. Порядок следования выражений определяет их нумерацию.

В строке замены выражения представляются в виде: \n, где n — номер выражения в строке поиска.

Простой пример, поясняющий работу с выражениями

Будем редактировать предложение: Сережа ест грушу.

Строка поиска | Строка замены | Результат поиска и замены
(Сережа )(ест )(грушу). | \3 \2\1 | грушу ест Сережа.
 | \1\3 с хрустом \2 | Сережа грушу с хрустом ест .
 | \1и Катя едят \3 | Сережа и Катя едят грушу.
 | \1\2\3 и Катя \2\3 | Сережа ест грушу и Катя ест грушу.

Примеры поиска и замены

Строка поиска | Строка замены | Результат поиска и замены
([!^0013]^0013)([!^0013]) | \1^0013\2 | Вставка пустой строки между теми абзацами, между которыми пустой строки не было.
(^0013){2;} | \1 | Удаление пустых строк
^0032{2;} | ^0009 | Замена двух или более пробелов на табуляцию
^0032([.,:;\!\?]) | \1 | Удаление пробела перед знаками препинания ( . , : ; ! ? )
([0-9])^0032([0-9]) | \1^s\2 | Замена пробела между цифрами на неразрывный пробел
([0-9])^0032([A-Za-zА-яЁё]) | \1^s\2 | Замена пробела между цифрой и буквой (английской или русской) на неразрывный пробел
-([0-9]) | ^0150\1 | Замена дефиса перед цифрой на минус
\(([0-9])\) | [\1] | Замена круглых скобок вокруг цифры на квадратные

И еще три примера

Пример 1

Замена в документе фамилии Иванов на фамилию Петров сразу во всех падежах:

Строка поиска | Строка замены | Результат поиска и замены
Ивано([а-я]@>) | Петро\1 | Замена фамилии Иванов на фамилию Петров сразу во всех падежах

Конечно, такая замена возможна только с фамилиями, у которых одинаковые падежные окончания.

Пример 2

В документе очень много десятичных дробей. Часть дробей набрана через точку, часть — через запятую. Требуется произвести такую замену, чтобы сделать написание всех дробей единообразным.

Вот два варианта этой замены:

Строка поиска | Строка замены | Результат поиска и замены
(<[0-9]@).([0-9]@>) | \1,\2 | Десятичная точка будет заменена на запятую
(<[0-9]@),([0-9]@>) | \1.\2 | Десятичная запятая будет заменена на точку

Пример 3

Дан большой документ содержащий текст словаря компьютерных терминов следующего вида:

Alpha(nu)meric display - буквенно-цифровой (символьный) дисплей

Дисплей, предназначенный для работы с буквенной, цифровой и сопутствующей символьной информацией.

Alpha(nu)meric keyboard - буквенно(алфавитно)-цифровая клавиатура

Клавиатура для ввода кодовых представлений цифр и букв, имеющая маркировку символьного набора.

Alternate key - альтернативный ключ

Ключ поиска в базе данных, не указанный в качестве первичного ключа.

Alternate Mark Inversion (AMI) - чередующаяся инверсия единиц

Способ биполярного кодирования, в котором следующие подряд единицы (mark) кодируются сигналами с противоположными знаками.

В тексте нет никаких текстовых выделений. Общее число словарных статей — 30000.

Требуется:

  1. Найти все переводимые английские термины и выделить их полужирным начертанием. При этом все другие английские слова оставить в неприкосновенности.
  2. Дефис между английским термином и его переводом заменить на тире. При этом все другие дефисы оставить в неприкосновенности.

Т.е. найти все 30000 фрагментов текста отвечающих вышеприведенным условиям и сделать 30000 выделений полужирным начертанием и 30000 замен дефиса на тире.

В результате должно получиться следующее:

Alpha(nu)meric display — буквенно-цифровой (символьный) дисплей

Дисплей, предназначенный для работы с буквенной, цифровой и сопутствующей символьной информацией.

Alpha(nu)meric keyboard — буквенно (алфавитно)-цифровая клавиатура

Клавиатура для ввода кодовых представлений цифр и букв, имеющая маркировку символьного набора.

Alternate key — альтернативный ключ

Ключ поиска в базе данных, не указанный в качестве первичного ключа.

Alternate Mark Inversion (AMI) — чередующаяся инверсия единиц

Способ биполярного кодирования, в котором следующие подряд единицы (mark) кодируются сигналами с противоположными знаками.

Вот как эта задача решается за пару минут:

Строка поиска | Строка замены
(^0013[A-Za-z^0032\(\)]@)^0032- | \1^0032^0151

Для строки замены необходимо установить Формат: полужирный (Format: Bold). Для этого воспользуемся кнопкой Формат (Format).

Осталось нажать на кнопку Заменить все (Replace All) и насладиться результатом.

Вверх


Зеркальная печатать из Microsoft Word

Если у вас есть PostScript принтер, то проблема зеркальной печати перед вами не стоит. А если у вас нет PostScript принтера, то его с успехом сможет заменить программа Ghostscript — эмулятор языка PostScript. Ее использование придаст обычному принтеру все возможности PostScript принтера, в том числе и зеркальную печать. Дополнительно потребуется программа RedMon способная перенаправлять вывод печати из одной программы в другую (Ghostscript в описываемом случае).

Обе программы распространяются бесплатно.

Предположим, что необходимо организовать зеркальную печать на принтере HP LaserJet 2100.

Итак:

  • Прежде всего с сайта http://www.cs.wisc.edu/~ghost необходимо загрузить Ghostscript и RedMon. Загрузить их можно, например, отсюда:
    Ghostscript | ftp://ftp.cs.wisc.edu/ghost/aladdin/
    RedMon | ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/
  • Теперь программы надо установить. Предположим что был загружен Ghostscript версии 7.00.
  • Ghostscript устанавливаем в каталог C:\GS. Для этого запускаем программу установки и указываем путь для установки C:\GS.
  • Чтобы установить RedMon надо просто разархивировать RedMon.ZIP в любой временный каталог и запустить Setup.EXE. После сообщения об успешной установке временный каталог с файлами дистрибутива можно удалить.
  • Теперь используя сервис Принтеры на Панели управления устанавливаем драйвер PostScript принтера HP LaserJet 5/5M PostScript. В диалоге выбора порта принтера следует указать RPT1 (если RPT1 в списке нет, то жмем кнопку Добавить порт и выбираем Redicted Port). От предложения напечатать пробную страницу следует категорически отказаться, иначе система может зависнуть.
  • Используя любой текстовой редактор (например, Notepad) в каталоге C:\GS необходимо создать файл с именем ljet4.rsp и вписать в него следующие строки:

    -IC:\GS\gs7.00\bin;C:\GS\fonts
    -sDEVICE=ljet4
    -r600x600
    -dNOPAUSE
    -dSAFER
    -sPAPERSIZE=a4
  • Теперь необходимо настроить параметры принтера и порта.
  • В свойствах принтера HP LaserJet 5/5M PostScript на закладке Сведения жмем кнопку Очередь. В диалоге надо обязательно отключить двусторонний обмен данными. Формат данных в очереди должен быть RAW. Закрываем диалог.

    Теперь жмем кнопку Параметры порта. В диалоге RPT1: Properties указываем следующее:

    в строке Redirect this port to the program пишем:

    C:\GS\gs7.00\bin\gswin32c.exe

    в строке Argument for this program are:

    @C:\GS\ljet4.rsp -sOutputFile="%1" - (с дефисом на конце!)

    Ниже выбираем:

    Output: Copy temporary file to the printer

    Printer: HP LaserJet 2100

    Закрываем диалог.
  • Теперь на закладке с настройками Post Script снимаем галочки у Ctrl+D.
  • На закладке Графика указываем печать зеркального изображения.

На этом настройка завершена. Если у Вас есть сеть, то HP LaserJet 5/5M PostScript можно сделать общим принтером.

Для зеркальной печати из Microsoft Word в диалоге печати выбираем принтер HP LaserJet 5/5M PostScript и печатаем.

Если документ содержит полутоновые изображения, то может понадобиться добавить в ljet4.rsp строку:

-dDITHERPPI=50

и опытным путем подобрать оптимальное значение.

Обратите внимание, что в файле ljet4.rsp строке -sDEVICE=ljet4 задается устройство (device) ljet4. Под устройством здесь понимается не конкретная модель, а целая группа принтеров. Подробнее о выборе device для других принтеров и описание прочих параметров см. в документации к Ghostscript.